Cloud Direct - Degraded Performance New York Datacenter

Incident Report for Arcserve

Resolved

This incident has been resolved.
Posted May 29, 2026 - 10:04 UTC

Identified

We're currently aware of a connectivity issue affecting our NY/New Jersey datacenter for the Cloud Direct product. Users may experience delays in backups when writing to these datacenters.

Other locations are unaffected and we will update you shortly when normal service has resumed.
Posted May 29, 2026 - 07:52 UTC
This incident affected: Arcserve Cloud Console (Cloud Direct / UDP) and Arcserve Cloud Direct (Arcserve Cloud Direct US-NY).