StorageCraft Cloud Outage - Canada
Incident Report for Arcserve
Resolved
This incident has been resolved.
Posted Jun 22, 2022 - 21:08 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 22, 2022 - 15:37 UTC
Update
We are continuing to investigate the issue.
Posted Jun 22, 2022 - 10:05 UTC
Investigating
We are currently investigating this issue.
Posted Jun 21, 2022 - 17:29 UTC
This incident affected: Arcserve Cloud Services (DRaaS) (Arcserve Cloud Services (DRaaS) Canada, Arcserve Cloud Services (DRaaS) GCP Canada).