Arcserve Cloud Direct - EMEA Outage

Incident Report for Arcserve

Resolved

This incident has been resolved.
Posted Jan 29, 2026 - 05:10 UTC

Investigating

We are currently investigating a connectivity issue with our European (UK) Datacenter. Updates will be provided as soon as possible, but backups and restore functionality for Cloud Direct may be affected during this time.
Posted Jan 28, 2026 - 22:00 UTC
This incident affected: Arcserve Cloud Console (Cloud Direct / UDP) and Arcserve Cloud Direct (Arcserve Cloud Direct UK).