Cloud Direct / Cloud Hybrid Partial Outage (UK/EMEA)

Incident Report for Arcserve

Update

We are continuing to work on a fix for this issue.
Posted Oct 30, 2025 - 00:23 UTC

Identified

We're working with our service provider at the UK datacenter to resolve this issue - further updates will be provided soon.
Posted Oct 29, 2025 - 18:24 UTC

Update

We are continuing to investigate this issue.
Posted Oct 29, 2025 - 17:39 UTC

Update

We are continuing to investigate this issue.
Posted Oct 29, 2025 - 14:53 UTC

Investigating

We are currently investigating an issue in communications with our UK datacentre. Some users with UK/European based services may experience a temporary loss of service while we work on restoring normal service.
Posted Oct 29, 2025 - 13:34 UTC
This incident affects: Arcserve Cloud Console (Cloud Direct / UDP), Arcserve UDP Cloud Hybrid (Arcserve UDP Cloud Hybrid UK), and Arcserve Cloud Direct (Arcserve Cloud Direct UK).