Global Outage Cloud direct.

Incident Report for Arcserve

Resolved

This incident has been resolved.
Posted Apr 04, 2026 - 07:56 UTC

Update

We are continuing to investigate this issue.
Posted Apr 04, 2026 - 07:54 UTC

Update

We are continuing to investigate this issue.
Posted Apr 04, 2026 - 07:26 UTC

Investigating

We are currently investigating the issue preventing the website from loading and backups from running.
Posted Apr 04, 2026 - 07:20 UTC
This incident affected: Arcserve Cloud Direct (Arcserve Cloud Direct JP, Arcserve Cloud Direct US-CA, Arcserve Cloud Direct US-NY, Arcserve Cloud Direct UK).