EU and US License Management portals Down
Incident Report for Arcserve
Resolved
This incident has been resolved and service has been restored to the Management portals.

Regards,
Arcserve Support
Posted Jul 19, 2024 - 19:20 UTC
Investigating
We would like to inform you that currently we are experiencing issues with Management portal(s). .This is currently being investigated. We apologize for any inconvenience.
Posted Jul 19, 2024 - 10:02 UTC
This incident affected: Management Portals (License Management Portal EU, License Management Portal US).