Arcserve Emergency Maintenance Notification: Cloud Hybrid instances US, starting on Aug 11, 2025, Time: 09:30 AM UTC

Incident Report for Arcserve

Resolved

This incident has been resolved.
Posted Aug 15, 2025 - 02:52 UTC

Investigating

As part of our continued efforts to provide stable services, we are performing maintenance on Cloud Hybrid instances in US DC. The purpose of this event is to ensure the continued security and reliability of your Cloud Hybrid Instance.

Our team will be performing a critical upgrade to the latest version of Arcserve UDP. Arcserve UDP is specifically designed to address modern cyber threats, including new security vulnerabilities and ransomware. By performing this upgrade, we will be applying the latest security patches and enhancements from Arcserve. During this maintenance window, you may experience brief interruptions in service. ​

Note: You will receive a separate notification prior to the scheduled upgrade of your specific instance and after your instance maintenance is completed.

Maintenance Start:11th Aug, 2025 @ 9:30 AM UTC
Maintenance End: 14th Aug, 2025 @ 1:30 PM UTC

We apologize for any inconvenience this may cause and appreciate your patience as we work to protect your data and enhance the performance of your service. ​

Regards,
Arcserve Support
Posted Aug 11, 2025 - 04:34 UTC
This incident affected: Arcserve UDP Cloud Hybrid (Arcserve UDP Cloud Hybrid US-CA).